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Error-0517: Missing GL Account

Symptoms

When pushing AP Invoices, you get the error message: [Spectrum Error] Distribution G/L account cannot be blank or empty.

Causes

This error occurs because one or more pricebook items on the AP Invoice is missing a GL account.

How to fix

  1. Navigate to the AP Invoice in Agave
  2. Click on the "Sync Status" for that record
  3. Expand the line items to see which ones are missing GL accounts
  4. Add Expense Accounts for those Pricebook Items under Materials or Equipment

Still having trouble?

Contact Agave Support or your account manager for help.