Skip to main content

Error 0001: A Customer with code XXXX already exists in Spectrum

Symptoms

When pushing Customers, you get the error message: A Customer with code XXXX already exists in Spectrum.

Causes

This error occurs because a record with the same identifier already exists in that company. There are a few possible causes:

  1. The records are the same: it has been entered by your team in both ServiceTitan and Spectrum.
  2. The records are different: but have the same identifier (e.g. the vendor document number entered is not unique, and another AP Invoice already exists with the same number)

How to fix

If they are the same record:

  1. Link the Record: link the Customer to the existing Customer in Spectrum.
  2. Check for Duplicates: if you cannot link the Customer, it means there is a duplicate entry in your accounting system. In this case, you can:
    1. Delete or consolidate the duplicate Customer in your accounting system,
    2. Ignore the duplicate record, or
    3. Update the name of the duplicate Customer to make it unique.

If they are different records:

Update the identifier of the duplicate record in the source system.

Still having trouble?

Contact Agave Support or your account manager for help.